Page 1 of 1

PostPosted: Fri Jan 30, 2009 3:50 pm
by the_whaler
Hi all.
I am trying to make a symlink form my freesco box (v038) to a shared directory on one of the xp machines in my network. This machine runs a program called FSD that is used for flightsimulator people to connect to with FSInn to fly with each other. This program creates a txt file that can then be read by another program over the internet to see on a map where one is and who else is there.

This txt file has to be served via a webserver (I use apache) in a subdirectory form the www files. I have tried having FSD write directly in this directory but that does not work for some reason. I made a share in the freesco (using Samba) and I had XP map that drive (so it now was z:\ and added this to the config of FSD. No luck. I can create files from the XP machine in this directory so I do not think it has something to do with writing allowences (so to speak).

Now I thought of trying to do it the other way. Connecting from Freesco to the xp share. I first tried Ln -s but no luck and now smbmount.

I use the following syntax.
smbmount / /home/rest/lecakyme -n

However I constantly get the following reply
mount error: Device or resource busy
Please look at smbmount's manual page for possible reasons

This is confusing to me. Does this mean the share is busy (yes I hope so) sometimes the server writes into there, or is the /lecakyme busy (again I hope so, also my apache should be there).
So in other words I am lost. To make sure it was not the xp share I have changed the config file of fsd (once again) so it writes somewhere else, yet the message stays the same.
Any help would be appreciated (are there any logfiles to be viewed?).

Thanks in advance.
The Whaler

PostPosted: Fri Jan 30, 2009 4:12 pm
by Lightning
I made a share in the freesco (using Samba) and I had XP map that drive (so it now was z:\ and added this to the config of FSD. No luck.

The reason this fails is because of directory permissions. The simple way around this is to make the directory writable to everyone with this command

chmod 777 /dir/dir-name

This will make the /dir/dir-name read/write/searchable to everyone. If security is a concern then there are a lot of other ways around this issue that are more secure.

PostPosted: Sat Jan 31, 2009 3:20 am
by the_whaler
Thanks Lightning.
I did try to change the settings via MC but that did not help (write by others). indeed for security reasons I did not use 777 but i have done this now just to see what happens. However come to think of it I even think the rest of this dir is 777 and I have not been hacked so far.

PS: Thanks for the good work. I saw you released an update for version 4. I have not been able to get the 4.0 working on the floppy (it hung after first restart) but havent had the time to look into this (just at one time made the floppy to see what would happen). Perhaps v4.1 will be correct immidiatly the first time.

PostPosted: Sat Jan 31, 2009 3:57 pm
by the_whaler
still no luck, not even with chmod 777 on both the directory and the files.
I even set the service on the xp machine to run as a local useraccount that is also known on the freesco box.
It does let me feel, the fsd software is somehow not capable of doing what it needs to do, although using a directory on the local machine works.

Brings be back to the origional question. Is it possible to mount withing freesco a network share on another machine as a local directory.

In casu.

/home/.../whazzup would then link to /localip/whazzup share.

I have also posted a question in the forum of the software creator.
see link
<a href='' target='_blank'></a>


PostPosted: Sat Jan 31, 2009 5:29 pm
Can you open a link to the file using FTP? You can use Explorer in XP with FTP to show the FTP folder as shared folder, just like a shared folder via regular windows netwrk share.

PostPosted: Sun Feb 01, 2009 5:38 am
by the_whaler
Although I was not really sure what you would like to achieve, I did try this but no luck. Not suprising as there is no ftp server running on the xp machine.
Although I dit think of starting the html server in xp and making a dyndns with specific port for this use.


PostPosted: Sun Feb 01, 2009 9:43 am
Use the FTP server built into Freesco, then link to it from your machine using Windows Explorer to test if the file transfers ok then.

How about posting your SAMBA configuration?

PostPosted: Sun Feb 01, 2009 1:37 pm
by the_whaler
good thinking.
for info whazzup is supdirectory of lecakyme

PostPosted: Sun Feb 01, 2009 2:23 pm
by the_whaler
Problem solved.

Still he link via a mounting in xp does not work.
But making a direct connection in the software of the server (fsd.cfg) does work provided you make the good entry and there i went wrong the first times.

I made a entry called \\intern.ip\whazzup\
because for instance the mapping in xp meant it was like that.
But as whazzup is a subdirectory of the share I should have used.

now it works.

thanks all for your suggestions.
but as they say if you find it yourself you will remember it better.
this I will never forget i think.

PostPosted: Sun Feb 01, 2009 3:37 pm
by Lightning
I would recommend adding these lines into your smb.conf file
        create mode = 0666
        time service = yes
        dos filetimes = yes
        fake directory create times = yes
        dos filetime resolution = yes
Also this line
        time offset = -0500

However you will need to play with this offset a bit because I am normally -0800 and -0500 is what I had to use to make it right. Of course of the above lines the only one that is really important is the "create mode = 666" line because otherwise files are created executable.

PostPosted: Mon Feb 02, 2009 4:26 pm
by the_whaler
Thanks lightning.
Added the lines (if it comes from a true gooroo it can only be good).
The time offset with GMT in the Netherlands is 0200 hours in summertime, 0100 in winter so I added 0100 for now. I am planning an upgrade to 041 in the near future (time is as always an issue) and if I read correctly there is even an option for summertime correction in the 04 seriers (perhaps also 03 but I am not aware of that option).

The 0666 I can imagine, did try to find in the help files of samba at the time if there was something to add as general but I did not understand all the technical english at the time (or now for that matter) I was glad to have it working.
Even Swat did not completely help me for that matter but it made life (config) easier.
The other options are rather peculiar to me. What do they do?

PostPosted: Mon Feb 02, 2009 6:41 pm
This might be of assistance:

<a href='' target='_blank'></a>

The FTP thing would not work, I misread the direction of file transfer/reading.

PostPosted: Mon Feb 02, 2009 9:38 pm
by Lightning
Hehe all of the other options are really of no real importance in most cases except when the file creation time is a factor and you may be dealing with some DOS systems.
(time is as always an issue)
Actually starting in the later of the 03x series and now in the 04x series you no longer have to change the time offsets in FREESCO. If you download the file you will find a "timezone" directory. You just copy the correct timezone file to the /boot/tmz/ directory of FREESCO and reboot the system. The system will then automatically change time offsets. Of course the problem this creates for Samba is that you then have to adjust the time offset inside of the smb.conf file to be correct for the file timestamps because it will not be what you think it should be.