Group-office Compatible Php5 + Aspell

3rd Party Package Requesting

Postby macca » Mon Jan 29, 2007 7:36 pm

Does any one know how to compile php5 with following extentions
USE='apache2 cli calendar iconv imap mysql memlimit'

these are required to run this real great php groupware 2.16 that has an "outlook" look and fell... with addressbook, calendar, imap + pop3 mail client with spellcheck, bookmarks, todo's proberly one of the best php look and feel....

im not able to compile via zipslack as i just dont know how to add these other extensions....

I have this running on gentoo but it would make a cool addition to freesco
demo minus mail here
<a href='http://www.group-office.com/index.php?folder_id=1&file_id=394' target='_blank'>http://www.group-office.com/index.php?fold...d=1&file_id=394</a>

spose this would be a bit of work just wish i was as upto date with freesco as i am with gentoo

Regards
Macca
User avatar
macca
Newbie
 
Posts: 4
Joined: Sun Mar 10, 2002 5:58 am

Postby dRB » Tue Jan 30, 2007 12:27 pm

quite the loaded application.

You may not need php5 for this...
<a href='http://www.group-office.com/index.php?folder_id=264&file_id=415' target='_blank'>Requirements</a>

When I run their test script, I get the following results:
Group-Office test script
Configuration tests
PHP version:  Ok (4.3.1)
MySQL support:  Ok
IMAP support:  Ok
Iconv support:  Warning: iconv extension not installed, E-mail module will be unreliable with character encodings.
File upload support:  Ok

Passed, Group-Office should run on this machine


So, maybe this is all that is needed to overcome the email module character encoding problem:
<a href='http://www.gnu.org/software/libiconv/' target='_blank'>Iconv</a>

-dRB
Please bear with me ... I seemed to have lost my marbles.
User avatar
dRB
Junior Advanced Member
 
Posts: 196
Joined: Tue Apr 30, 2002 2:08 am
Location: Dryden, Ontario. CANADA

Postby dingetje » Tue Jan 30, 2007 6:06 pm

Looks like the app. might work, with the exception of special characters handling in email messages.

What you've asked is a LOT of work, or put a little bit different "a challenging, rewarding project that will leave you with the satisfied feeling of having learned a lot and the gratification and admiration of your peers" ;)

I've tried Apache 2 in the past, but found it less stable then Apache 1.3 on FREESCO, but Apache 2 branch has come a long way since, so maybe worth another try.
However PHP 5 I've never tried to compile on zipslack, so don't know if its even possible.

Using a bare bone zipslack 3.9, expect a lot of library upgrades to meet the minimum requirements!

For what its worth, I have upgraded my Apache to 1.3.37 and PHP 4.4.4 last weekend. This PHP module is a bit less extended then in my Apache 1.3.27 package (f.i. it lacks the IMAP module), but my portal, the DokuWiki and the FAQ all seem to work after the upgrade.
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby PHBC50 » Tue Jan 30, 2007 7:13 pm

Yes, iconv itself requires XML libraries like libsablot and libxslt which are not easy to compile...it would be really nice to have those on FREESCO though!

PHBC50
The only way of discovering the limits of the possible is to venture a little way past them into the impossible. (Arthur C Clarke)
User avatar
PHBC50
Junior Advanced Member
 
Posts: 139
Joined: Thu Nov 21, 2002 8:59 pm
Location: France

Postby Lightning » Tue Jan 30, 2007 9:52 pm

As I have libiconv installed on my machine, I don't think that libiconv is the issue. Because I also got the same test results. I am however wondering if PHP knows about libiconv ??
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Postby PHBC50 » Wed Jan 31, 2007 12:19 am

:wink: my bad, I was thinking of the domxml php extension, which requires libxslt and is now included in php 5 (though not in a PECL module).
I've ran into it while trying to get horde running on FREESCO, unfortunately this was a required module and there is no plugin for php 4 to build this extension with php...

As for iconv, many webmail applications, like my nocc package...need it, so it would be great to include it in a new package of apache/php.

PHBC50
The only way of discovering the limits of the possible is to venture a little way past them into the impossible. (Arthur C Clarke)
User avatar
PHBC50
Junior Advanced Member
 
Posts: 139
Joined: Thu Nov 21, 2002 8:59 pm
Location: France

Postby dRB » Wed Jan 31, 2007 1:03 am

I am however wondering if PHP knows about libiconv


You are of course correct. It appears that php needs to be compiled with iconv support. And with php 4.3.1, very little xtra work to do so. :rolleyes:

<a href='http://ca3.php.net/iconv' target='_blank'>http://ca3.php.net/iconv</a>

-dRB
Please bear with me ... I seemed to have lost my marbles.
User avatar
dRB
Junior Advanced Member
 
Posts: 196
Joined: Tue Apr 30, 2002 2:08 am
Location: Dryden, Ontario. CANADA


Return to 3rd Party Package Requesting

Who is online

Users browsing this forum: No registered users and 6 guests

cron