Page 1 of 1

edrive for 0.4.x?

PostPosted: Sat Sep 25, 2010 2:40 pm
by lgrfbs
Can someone port:
edrive_1.02_gnork package
to the 0.4.x system?

Re: edrive for 0.4.x?

PostPosted: Sun Sep 26, 2010 2:27 am
by Lightning
The use of the edrive package is degraded in the 04x series due to the extra command options in the /rc/rc_user script. It would be much more beneficial to use that script in the "$boot)" and "shutdown)" sections to manually mount extended drives and file systems over using a package. Although the base information in the package for drive numbers/devices is quite useful, along with the hdparm information. However if you provide the basic information on what you want to mount and use then I would be more than happy to give you the detailed instructions on how to do it.

Re: edrive for 0.4.x?

PostPosted: Mon Sep 27, 2010 11:50 am
by lgrfbs
okey.
Part of my old edrive.cfg file wrote: EMAP1=/mnt/bootdev/router/www # foldername created for mount
EDEV1=/dev/hdb1 # device name to mount
ETYP1=ext2 # vfat filesystem type: umsdos, vfat, ext2
EOPT1=-rw # extra options for the mount command if you desire
EMNT1=Yes # mount this drive at rc_edrive start (Yes or No)
ERMT1=No # unmount then remount if already mounted (Yes or No)

EMAP2=/mnt/bootdev/router/www_backup
EDEV2=/dev/hdc1
ETYP2=ext2
EOPT2=-rw
EMNT2=Yes
ERMT2=No

The original www folder shall be moved/renamed of course before mounting the new www folder.

Re: edrive for 0.4.x?

PostPosted: Mon Sep 27, 2010 6:41 pm
by Lightning
Ok, here is how to duplicate that to work in the 04x series without that package.
edit /rc/rc_user
Code: Select all
# At top of script un-comment this line
.  /etc/colors

$boot)
    [ -d  /mnt/bootdev/router/www ] || mkdir  /mnt/bootdev/router/www
    echo -n "Mounting hdb1 to www directory...$HT"
    mount -t ext2 /dev/hdb1  /mnt/bootdev/router/www >/dev/null 2>&1
    = $?
    echo -n "Mounting hdc1 to www_backup directory...$HT"
    [ -d  /mnt/bootdev/router/www_backup ] || mkdir  /mnt/bootdev/router/www_backup
    mount -t ext2 /dev/hdc1 /mnt/bootdev/router/www_backup >/dev/null 2>&1
    = $?
    ;;
shutdown)
    echo -n "Un-Mounting /dev/hdb1..."
    umount /dev/hdb1 >/dev/null 2>&1
    a=$?
    [ $a = 0 ] || echo -n "read-only mode"
    [ $a = 0 ] || umount -r /dev/hdb1
    echo -n "$HT"
    =  $a
    echo -n "Un-Mounting /dev/hdc1..."
    umount /dev/hdc1  >/dev/null  2>&1
    a=$?
    [ $a = 0 ] || echo -n "read-only mode"
    [ $a = 0 ] || umount -r /dev/hdc1
    echo -n "$HT"
    =  $a
    ;;

Re: edrive for 0.4.x?

PostPosted: Thu Sep 30, 2010 2:53 pm
by lgrfbs
Thanks, all working just fine.