[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
FREESCO Support • View topic - Boot media or drive problem, error

Boot media or drive problem, error

Support section for FREESCO v0.3.x

Boot media or drive problem, error

Postby Thasaidon » Sat Oct 31, 2009 3:20 pm

Hi,

I have Freesco 038 running on a Laptop with no problems, except for a flaky PCMCIA Ethernet adapter.
And since I'm getting a fiber connection instead of my current ADSL, I want to change to a desktop system with regular PCI Ethernet adapter.

So what I wanted to do, was copy the HD contents from the laptop HD to a desktop HD, so I don't have to reinstall everything from scratch.
I've done that before without problems and it seems the most easy way.
The other reason I don't want to reinstall is because the desktop hasn't got a floppy drive (yet).

After having copied the laptop HD to the desktop HD, all seems fine, and Freesco seems to boot, but then I get the message:
Boot media or drive problem
and Freesco stops loading. (this is right after the nice penguin walking across the screen :D )
I do get a login prompt where the user/pass are default root.
but other than that, nothing much seems to work.

I also tried to put one of my "Drive Image" backups on the desktop HD, but that gives the same result.
Since all the files and folders are on the desktop HD, there should be no problem.
Both checkdisk and scandisk show no problems.
Both HD's are FAT32, formatted with the same tools, and equal in size.

The only thing I can think of is that the drive on the Laptop is seen as HDA1, and the drive in the desktop seems to be SDA1 (at least that's what an Ubuntu Live-cd tells me).
I already changed the BOOTDEV=hda1 entries to BOOTDEV=sda1 entries in my autoexec.bat (router.bat), but that doesn't work.
Also, when I do an dmesg |more and look for any HD detection, all I see is hda: cdrom... which is the CDROM drive.
The only other entry is an ide0 at 0x1f0-0x1f7, 0x3f6 on irq 14

How can I make sure the drive in the desktop is actually SDA, and not HDA? Is Ubuntu correct in this?
And how do I manipulate Freesco in running from SDA1 and not HDA1? If that is at all possible...

I'll try to get a floppy installed in the system, so I can at least get some info on a floppy if needed.

Any help would be appreciated
Thanx in advance
Last edited by Thasaidon on Sat Oct 31, 2009 3:48 pm, edited 1 time in total.
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Thasaidon » Sat Oct 31, 2009 3:35 pm

Mmm...
I should have looked before I posted...
It turns out the HD in the desktop is a SATA drive. The drive in my laptop is an ATA.
So I guess Ubuntu was correct in seeing the drive as SDA instead of HDA.

My bad :oops: :oops: :oops:

Now the question remains...
How can I, if even possible, manipulate Freeso to run on the new SATA HD?
Or do I need a special kernel for SATA drives?
I'm currently running the "kernel-038.cd-686-triton-vipc-power_off"
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Sat Oct 31, 2009 6:40 pm

If you have the "Triton" kernel installed on the floppy and it is still not recognized then the ONLY possibility is to try the 04x system with one of the 04x "Triton" kernels installed on the floppy. There was some updates made for more SATA support added into the 04x kernels which MIGHT support your hard drive controller.

Past that it would require some detailed information on your hard drive controller and making some changes to the kernel source to compile a special kernel. Which is not completely out of the realm of possibilities.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Sun Nov 01, 2009 5:06 am

Thanx for the reply.
I was hoping for a "quick fix" on this one. But as in life, sometimes there are no shortcuts :D :D

However, I'm wondering if a "special drive controller" would be needed.
I managed to install a floppy drive on the system, and was able to boot with a win98 bootflop (like I did with all previous Freesco systems).
And while booted with this, I could access the drive without problems. Scandisk, FDISK and Format also worked ok.
As far as I know, win98 doesn't have any special drivers for SATA?!

So my guess is to check out some settings in the system BIOS, maybe there's something there that can help.
Some option like "Run SATA as IDE" or something...

Otherwise I can try and put in an ATA HD, but I need some special parts to do that.

If all else fails, I'll try a 04x floppy.
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Sun Nov 01, 2009 11:52 am

The reason Windows 98 works is because it uses the BIOS to set all of the parameters for the drive. Which in Linux the BIOS settings are never used and the drive it's self is read for all of the parameters. So when using a SATA drive the controller must be supported to get those settings. If an 04x "Triton" kernel does support this drive it will most likely be shown as hda and not sda.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Sun Nov 01, 2009 12:46 pm

Thanx, I didn't know that about 98, Linux and the BIOS.

In the mean time, I've used another Linux Live-cd to do some stuff on the system, and it too sees the drive as an SDA.
so what are the chances the 04x Triton kernel will work and see the drive as HDA?

Otherwise I'll just try and see if I can get a regular ATA drive in the system.

thanx again.
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Sun Nov 01, 2009 4:20 pm

If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Mon Nov 02, 2009 10:20 am

Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Mon Nov 02, 2009 8:23 pm

If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Tue Nov 03, 2009 2:40 am

Thanx,

I'll give it a try and let you know asap :)

I take it the 040 kernel also works with Freesco 042?, because I can't find any 042xxtritonxx kernel?
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Tue Nov 03, 2009 9:15 pm

Yes the 040 kernel will work fine in 042.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Wed Nov 04, 2009 12:57 pm

Well, here's what I've been doing...

Since this desktop system is going to be my replacement for my current laptop (with pcmcia interface errors) and I'm switching ISP's on December 1st,
I needed a quick fix...
So I installed a regular ATA HD, and tried to put my Freesco backup image on it, but I got the same problem as with the SATA HD.
Then I messed around in the BIOS with the drive/IDE/SATA settings, and after a while I got the ATA HD working ok with the restored image of my Freesco 038.

So... since I now have a working solution and being the stubborn *ass that I am... I figured if BIOS settings would get a normal IDE HD to work, I could try and see if I could get the SATA HD to work with some BIOS tweaks too.

And after fooling around some more with the BIOS settings, I got the SATA HD now running and it's also seen as HDA1 :D :wink: :D
I again restored my 038 image onto the SATA HD, and everything seems to work just fine now! :D :D :D

I also tried booting the system with the default(!)042 floppy to see if there was any difference in the dmesg and /proc/pci
so here are the files if your interested.




If you'd like to see more, just let me know.

I will certainly try and get 042 running, but for now, not on this system, because this will be my primary system from now on.
But I now have a spare laptop again to test 042 on :D :D

Thanx for all the help! I always appreciate it!
Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Re: Boot media or drive problem, error

Postby Lightning » Wed Nov 04, 2009 8:38 pm

Unfortunately I am not really seeing any information in the /proc/pci file to tell anything about the hard drive controller. So there isn't much to do past that if it is working. But the 036+ kernels did have some SATA support included in the Triton kernels as I recall and it was enhanced a bit more in the 04x kernels to support more devices.

As for the 04x system, it has quite a few enhancements over 038. But there is nothing specifically wrong with 038 that would force an upgrade at this time. However specifically for any type of critical system I will definitely recommend looking at 043 real hard when it comes out because it will include software raid so you can have hard drive and data redundancy built into the system with raid0 and two drives or just better throughput if you want with raid1 or raid5 using three or more IDE hard drives.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Boot media or drive problem, error

Postby Thasaidon » Thu Nov 05, 2009 5:43 am

Experience shared, is experience gained.






Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands


Return to FREESCO Support for v0.3.x

Who is online

Users browsing this forum: No registered users and 1 guest