[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
FREESCO Support • View topic - Dial-out router mode not working
Page 1 of 1

Dial-out router mode not working

PostPosted: Fri Feb 17, 2012 5:45 pm
by phillipsjk256
Hello,

I still have not retired my freesco router. I recently got dial-up Internet access to try to figure out why my e-mail doesn't work (I no longer trust my ISP).

Anyway, when I boot in dial-up router mode on a test machine, nothing happens. If I login as "up" I get the following message: "Command 'up' has just been sent" .... and nothing happens.
After reading about the modem intialization bug in 0.4.x, I went back and added an initialization string for modem0 (with the same results). During boot, no network cards were detected. Would that prevent dial-out?

I was able to successfully dial-out under Win98 (with the same machine). Knoppix failed PPP negotiation for some reason. A "NO CARRIER" response occured several times, so the line may be noisy (freesco does not even make the modem go off-hook). The modem is external.

Instead of switching to dial-up mode, I would prefer to leave the router in ethernet mode and have the modem link become the default route when in use. Is there an easy way to do that?

I had to change my user name for my ISP link. I failed to select my ISP as expected in menu 81. With no ISP selected, option 811 "Edit selected ISP" prompts you with option 822 "Define new ISP", which gives you an error message when you type in an existing ISP. I was under the impression the 'default' ISP would be selected automatically. I was able to edit things after accidentally typing the ISP name (selecting an ISP according to the computer).

Re: Dial-out router mode not working

PostPosted: Sat Feb 18, 2012 5:51 am
by Lightning

Re: Dial-out router mode not working

PostPosted: Thu Feb 23, 2012 3:01 pm
by phillipsjk256

Re: Dial-out router mode not working

PostPosted: Fri Feb 24, 2012 12:46 am
by Lightning

Re: Dial-out router mode not working

PostPosted: Fri Feb 24, 2012 4:28 am
by phillipsjk256
Thanks, it is working like a charm now.

I may still try 0.4.4 because I want to do a month-long bandwidth study before deciding how much to spend on Internet access. I think 0.4.4 should be able to run on my existing router with only minor tweaks to accomodate the mono screen and limited memory.

I suppose I should write some kind of howto document explaining this. Just creating a dial-out ISP entry and typing "mode dailup" is much simpler than the disk swapping I was envisioning.

Is there any easy way to disable dial-in just for the modem? I am not sure I want to leave it in autoanswer mode. (I could just disable dial-in altogether since I have not used the null modem cable in years.)

PS: Every packet on the modem link is logged. The messages on screen 3 stopped updating after reaching some limit (after about 40K packets). It does not appear to "fix" itself when I switch back to ethernet mode.

Re: Dial-out router mode not working

PostPosted: Fri Feb 24, 2012 9:37 pm
by Lightning
I am VERY glad you got it working. ;)

In the server section of the setup in the 04x series you can disable the RAS (Remote Access Server) so that it will not allow dial-in. In the 03x series it is in the advanced settings section option #52.

As for packet accounting in 03x for the modem.... I am unsure of any limitations for logging. I have not really done very much testing of the dial-out mode of FREESCO in quite a long time and even then it is through a phone line simulator and not a real world application. I have sort of figured if it ain't broke don't change anything and it should be fine. :roll:

P.S. if you write a howto I would be more than happy to post it in the FAQ section of the forum. FREESCO is really designed to do exactly what you are doing, but not many are actually using it's capabilities or possibly even know about them. Years ago it was important to have multiple dial-up ISP's and now most everyone has a high speed connection.

Re: Dial-out router mode not working

PostPosted: Sat Feb 25, 2012 12:27 pm
by phillipsjk256